Raspberry Pi – Problem bei “apt-get update“

PWR ACT LED Raspberry Pi2 Pi3 B +Problem bei “apt-get update“

Vor einigen Tagen habe ich meine Raspberry Pi Anordnung etwas umgestrickt.

Der alte Pi 2 ist temporär außer Betrieb und nur noch die 3er Version soll nun alle Aufgaben im heimischen Netzwerk übernehmen. Da er meine diversen Server für DLNA, NAS und auch ein kleines WordPress-CMS mühelos alleine schafft, kann so etwas Kabelsalat eingespart werden, nebenbei ist schlicht eine Installation weniger zu pflegen.

Seit dieser Aktion ist er auch zusätzlich an das kabelgebundene Netzwerk angeschlossen, so kann ich diverse Aufgaben an unterschiedliche Netzwerkinterfaces binden und muss auch bei Ausfall des Funknetzwerkes nicht gleich einen Bildschirm anklemmen, wenn ich via SSH oder VNC nichts mehr ausrichten kann.

Probleme beim Update der Quellen

Leider hat sich in den letzten Tagen ein kleines Problem aufgetan. Beim Versuch, das System mittels ‚apt-get update‘ auf dem Laufenden zu halten, tut sich zunächst nichts, der Fortschritt bleibt bei 0% stehen und irgendwann erscheint die folgende Meldung:

E: The repository ‚http://archive.raspberrypi.org/debian stretch Release‘ does no longer have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Nun, zunächst habe ich einen Fehler bei der Verbindung zur Quelle vermutet, was aber nicht der Fall ist.

Diverse Recherchen im WWW führen mal hier und mal dorthin, nichts passt wirklich. Ganz schnell wird auch geraten, Raspbian Stretch in die Tonne zu kloppen und Buster zu installieren, alles andere würde eh nicht lange halten. Nebenbei will ich das System aber in erster Linie für meine Einsatzzwecke nutzen und mich nicht vom System nutzen lassen, um über die Feiertage mein Linuxwissen zu vertiefen oder alles neu einzurichten ;-) Also weitersuchen, Google zu gezielten Ergebnissen überreden, Log’s lesen, Scripte sichten, all das Zeug eben.

In einem kleinen Post, bei dem der Autor nicht wirklich für voll genommen wird, berichtet er von einem ähnlichen Problem. Er hat ganz simpel auch von Wlan auf LAN umgestellt und ein ziemlich ähnliches Fehlerbild zu vermelden. Leider habe ich mir die URL nicht gemerkt, aber immerhin existiert nun ein Indiz für eine erneute Fehlersuche ;-)

Raspi IPv4/6Lösung

Ich mach’s kurz …

Bei der Inbetriebnahme des LAN-Anschlusses habe ich nur eben schnell die manuelle IPv4-Adresse vergeben, ohne explizit IPv6 zu deaktivieren, wie ich es aus Kompatibilitätsgründen hier eigentlich immer mache. Nun, ein Haken bei “Disable IPv6“ hat das Problem aus der Welt geschafft, das Maschinchen erledigt wieder brav seine Aktualisierungen.

Wenn jemand weiß, was da genau hinter steckt, wäre ich für eine Mail oder einen Kommentar dankbar :-)

 

 

 

Immer wieder, nach jedem großen Windows 10 Update: Die Webcam streikt.

Die Webcam im Streik?

Eigentlich vermeide ich es ja lieber, eigene Blogbeiträge mehrfach zu posten. Da ich aber in den letzten Wochen doch einige Mails bekommen habe, die sich um dieses oder ähnliche Probleme drehen, zitiere ich mich nun einfach selber ;-)

Leider bekomme ich nur von wenigen Lesern am Ende ein finales Feedback, ob es denn nun daran lag oder nicht. Hier am HP-Notebook kann ich jedenfalls fast immer davon ausgehen, dass nach größeren Windows 10 Updates die Kamera wie unten beschrieben aussteigt und der User händisch eingreifen muss.

Fehlerbild:

Eine Anwendung greift auf die Kamera zu, die Staus-LED springt kurz an und das war es auch schon. Die zugreifende Anwendung stürzt ab oder friert ein, die LED geht aus. Spielereien an den Treibern bringen nichts, am System selber ist alles wie immer und in der Vergangenheit lief das Gerät fehlerfrei.

Weiterlesen

AMD Radeon R7 M260/265 nach Windows 10 Update

R7 260/265Updatezicken

Ja, ich nutze ihn immer noch, den guten alten Pavilion 17F-258 ng ;-)

Abgesehen von einem nun doch schon nennenswerten Alter, läuft das Gerät eben zuverlässig. Wenn nur nicht Windows bei den Updates immer der Meinung wäre, es mit den Einstellungen und Treibern besser zu wissen :roll:

Wenn also nach einer solchen Zwangsverbesserung des Systems der Desktops verändert wirkt und/oder das Startmenü hakt oder gar nicht auftaucht, checkt die aktiven Grafikkartentreiber.

Es ist nicht das erste Mal, dass ich einen AMD Radeon R7 M265 Treiber ungefragt in den aktiven Einstellungen finde, wo eigentlich der AMD Radeon R7 M260 hingehört. Höher gleich besser? Nein! Mit dem 265er läuft der Pavilion schlich, entschuldigt das Wort, Scheiße!

Roundabout werkelt der Rechner mit der Treiberversion „amd-catalyst-15.7.1-win10-64bit“ immer noch am schnellsten und stabilsten. Zu finden im und beim Treiber Center vom AMD. Ein paar Zeilen zum Treiber, habe ich vor ein paar Jahren schon getippt ;-) Sollte vorher bereits das passende 260er-Paket aktiv installiert gewesen sein, kann man die richtige Version einfach aus den im System vorhandenen Treiber wieder hervorholen. Dazu im Gerätemanager die Funktion ‚Treiber aktualisieren‘ wählen und den mit der 260 im Namen, aus den bereits auf dem System vorhandenen Versionen auswählen. Während des Vorgangs wird der Bildschirm kurz schwarz, nicht erschrecken!

Nebenbei will nach dem Update auch die Webcam wieder nur Fehler produzieren, die Lösung zu diesem Problem, habe ich hier notiert.

Ich könnte mir vorstellen, dass manche Probleme im Ansatz auch auf anderen Maschinen hier ihre Ursachen finden, vielleicht hilft es ja :-)

 

 

 

Windows 10: Webcam streikt?

Irgendwann in den letzten Wochen habe ich bemerkt, dass meine Webcam am Laptop streikt. Ich benutze das Gerät wirklich selten, kann also daher nicht genau festlegen, in welchem Zeitraum das Problemchen aufgetaucht ist.

 

 

Fehlerbild:

Eine Anwendung greift auf die Kamera zu, die Staus-LED springt kurz an und das war es auch schon. Die zugreifende Anwendung stürz ab oder friert ein, die LED geht aus. Spielereien an den Treibern bringen nichts, am System selber ist alles wie immer und in der Vergangenheit lief das Gerät fehlerfrei.

Lange Rede, kurzer Sinn – hier lag es an Windows. Mit einem der großen Windows 10 Updates, gab es Änderungen im Zusammenhang mit den YUY2/MJPEG/H264 Umgebungen, manche Kamera mag das eben nicht,

Lösung: Mit Zwei zusätzlichen Einträgen in der Registry, läuft hier wieder alles, wie gewohnt!

(Registry ändern: Windowstaste + R -> ‚regedit‘ eingeben -> Links in der Liste die Schlüssel suchen. Wer jetzt nicht weiß, was gemeint ist, sollte sich das beim ersten Mal zeigen lassen, die Gefahr sein Windows zu ruinieren, ist durchaus gegeben! :!: )

Zu editierende Schlüssel:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Media Foundation\Platform

und

HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows Media Foundation\Platform

Einzutragen bzw. rechts neu anzulegen:

DWORD-Wert (32-Bit): EnableFrameServerMode

Wert: 0

 

Die Lösung habe ich mir übrigens auf diversen Webseiten zusammengesammelt, kommt öfter vor ;-) An dieser Stelle einfach ein pauschaler Dank an all die anderen Schreiber und Tüftler, deren Lösungen funktionieren, welche man aber im Durcheinander vergisst oder die nie genannt werden :-)

 

 

“Meltdown” und “Spectre” unter Windows | Ingos Blog

In „Ingos Blog“ gibt es einen netten Beitrag zum Thema Prozessoren und Sicherheitslücken:

Quelle: “Meltdown” und “Spectre” unter Windows | Ingos Blog

Konnte ich nicht unverlinkt lassen :-)

 

 

 

 

 

 

HP Pavilion 17f, Windows 10 Fall Creators Update

Kleine Info zum Thema „seltsames Verhalten aktualisierter Betriebssysteme“:

Microsoft verteilt gerade das „Windows 10 Fall Creators Update“, gestern Abend habe ich es für mein HP Pavilion 17f-258 Notebook angeboten bekommen und installiert. Nach rund 60 Minuten (eher etwas weniger, hab nicht die komplette Zeit neben gesessen ;-) ) war alles störungsfrei installiert. Bei der weiteren Nutzung ist mir allerdings ein leicht schleppendes Verhalten der verschiedenen Programme aufgefallen, welches vorher so nicht vorhanden war.

Kurze Suche, lange Folge:

Das Update hat einige der Treiber ungefragt auf die von MS gewünschten Versionen geändert. Vor allem die fehlenden Radeontreiber haben sich bemerbar gemacht, nicht zuletzt wegen Fehlverhalten der Tools zum Verwalten der Grafikkarte. Ich habe nun alles von Hand wieder mit den Herstellertreibern versorgt, bisher klappt’s. Ob allerdings noch irgendwo eine Verschlimmbesserung in der Art zu finden ist, kann ich noch nicht sagen, die AMD-Chipsettreiber habe ich gleich mit aktualisiert, mal sehen…

 

 

 

 

 

Gesammelte Downloads PICkit 2

Ich weiß leider nicht, wie lange die Seite bei „Microchip“ online und aktuell bleibt, jedenfalls hinterlege ich hier den Link, der zu den gesammelten Dowloads für den PICkit-2 Programmer führt.

 

 

 

Eher wieder ein Merker für mich, denke aber, auch andere werden schon gelegentlich nach ähnlichem suchen ;-)

 

 

 

 

 

 

 

Android 5.1.1 Sony Xperia™ Z1 Compact

z1_c_update_1Beinahe vergessen:

Auch für das Sony Xperia™ Z1 Compact gab es vor ein paar Tagen Android 5.1.1.

Wer also immer (auch) darauf wartet… ;-)

Die Installation verlief ohne irgendwelche Probleme, wie beim Tablet Z auch.

 

 

 

z1_c_update_2

 

 

 

 

 

 

 

 

 



 

Android 5.1.1 – Xperia™ Tablet Z / SGP321

xperia_lollipop_51.jpgWer hätte es gedacht? Plötzlich gibt es wieder einmal die Meldung: „Ein Systemupdate ist verfügbar“.

 

Hätte ich bei meinem, ja doch schon älteren, SGP321 bzw. Xperia™ Tablet Z gar nicht mehr wirklich erwartet ;-)

 

Knapp 370 MB groß, Download und Installation wie immer ohne nennenswerte Störungen, hat einfach alles gut funktioniert. Bin nach wir vor niemand, der sofort das komplette System auf den Kopf stellt um die Änderungen zu finden, bisher ist mir eigentlich eher nichts ins Auge gefallen.

xperia_lollipop_512.jpgVermutlich wird die Build 10.7.A.0.222 ja das letzte Update für diese Version des Tablets sein, jedenfalls was offizielles Material von Sony angeht?! Einfach mal abwarten…

Wenn also jemand händeringend auf dieses Update von „Lollipop“ bei diesem Gerät gewartet hat, kann er kurzfristig damit rechnen :-)

 

 

 

 

Windows 10 auf dem HP Pavilion 17f-258ng

HP_17f258ng-geraetSo, ich habe es getan, Windows 10 ist installiert!

Das wichtigste vorweg: Es funktioniert, bei 3 Treibern musste ich nachhelfen bzw. von Hand aktualisieren. Windows 10 möchte gerne noch einen Treiber für den ‚Wireless-Button‘ haben, zu finden auf dem HP FTP Server. Hier nach der Treiberdatei „sp64043.exe“ suchen. Für die anderen unbekannten Komponenten hat bei mir ein aktualisieren der Chipsatztreiber gereicht, bezogen über das AMD Treibercenter. Den aktuellen Windows 10 Grafikkartentreiber habe ich wieder entfernt, nach diesem lief das Display immer mit voller Helligkeit ohne Regelmöglichkeit. Aktuell werkelt hier wieder die Windows 7/64 Version Catalyst 15.7.1.

Das Upgrade habe ich über die Windows Updates bezogen, lief absolut problemlos innerhalb ca. 30-40 Minuten durch. Laut System ist Windows 10 bereits aktiviert, jedenfalls habe ich bisher hier nicht eingreifen müssen. Inkompatibilitäten oder anderweitige Effekte sind bislang nicht aufgetreten, gefühlt arbeitet das Notebook etwas schneller, der Rest wird sich zeigen :-)